Sent TOMOE tokens to my Tomo Wallet

Hello,

I sent some TOMOE tokens to my Tomo wallet (on my Ledger) because I got confused by process for token swaps. Is there any way to convert these tokens? I tried accessing this Tomo wallet using Meta Mask but I can’t find a way to change the HD derivation from ETH to Tomo (m/44’/889/0’/0). I have also tried adding ETH to move the TOMOE tokens none of the interfaces I use allows me to use that ETH as gas to move the TOMOE tokens.

Hi Hito,

Sorry I don’t quite understand your question. Are you trying to convert TOMOE to native TOMO on TomoChain? To convert TOMOE - TOMO, you can just use TomoBridge (see tutorial)

To log into TomoWallet with metamask, you just need to click on “import wallet” and choose metamask, and you should be logged in.

I hope I answered your question, or if not, could you explain a bit more about the issue that you are having?

1 Like

Hi Justin,

Thank you for responding and sorry for any confusion.

I have a Ledger wallet and I installed the TomoChain App on my Ledger. I created a TomoChain wallet using this link: https://wallet.tomochain.com/#/import-wallet. I chose the HD derivation of m/44’/889’/0’/0 and specifically created a TomoChain wallet. This wallet’s address is what I provided above: Address 0x8350017834939ced1e6918894d3aa3ca6f30b0b4 | Etherscan.

I was using that tutorial you provided but I got confused by the process and thought that it’d be easiest to just send the Tomo ERC20 tokens to my TomoChain wallet mentioned above. Right now, that TomoChain wallet has 96 ERC20 tokens attached to it and I can’t move them.

When I use TomoBridge, it asks me to link up to MetaMask but I can only choose the default HD derivation path which is an ETH wallet. I haven’t been able to find an option on MetaMask that allows me to choose an HD derivation path to my TomoChain Wallet, ie m/44’/889’/0’/0. Because I am unable to do so, I can’t access that wallet in order to do the TomoBridge conversion.

I have also tried opening up my TomoChain wallet (0x8350017834939ced1e6918894d3aa3ca6f30b0b4) on MyEtherWallet because MyEtherWallet allows me to choose the HD derivation path on my Ledger but I can’t move any of those tokens out and back onto a regular ETH wallet in order to the TomoBridge token swap via MetaMask. I tried sending some ETH to use as gas for this wallet, but the TomoChain wallet keeps giving me errors when I try and send the ERC20 tokens back to the original ETH wallet.

Is there any way I can convert these TOMOE ERC20 tokens on 0x8350017834939ced1e6918894d3aa3ca6f30b0b4 which is already a TomoChain wallet?

I hope that cleared things up a little more.

Hi Hito,

Thanks for the clarification.

I think the reason why you can’t “move” your TOMOE token could be that you are now on TomoChain network, but TOMOE is a ERC-20 token that’s hosted on Ethereum network.

and as you are trying to convert TOMOE to native TOMO, you should be on your Ethereum network, not on TomoChain network.

Could you send me some screenshots of the issue that you had while trying to log into TomoBridge?

and please also make sure you’ve read through this guide for Ledger users.

Hi Justin,

Here is a screenshot of the issue that I’m having on MyEtherWallet:

.

I added TOMOE as a custom token and I can see the token and the amount. When I try and send, I keep getting an error saying that I need to enable contract data on my Ledger apps. I have done so and triple checked to make sure; my ETH app has contracts checked ON and I have done the same for my TomoChain app. I still get this error nonetheless. I have also made sure to have the MyEtherWallet network be on Ethereum in order to send these ERC20 tokens but that doesn’t help.

For TomoBridge, I am unable to open my wallet on the TomoChain app on the Tomo network when MetaMask asks me. I am given this error: Imgur: The magic of the Internet

Just to be safe, I also tried to connect my Eth app wallet on the Eth network to MetaMask to make sure I didn’t have a connection issue with my Ledger wallet and I am able to connect my Eth wallet just fine: Imgur: The magic of the Internet

[For clarification: I believe I set up Tomo net on my MetaMask account correctly. I had a total of 800 TOMOE ERC20 tokens on my original Eth wallet. I test sent 96 ERC20 tokens to my Tomo Wallet mentioned above because I thought that was the easiest way to convert the tokens. After being mistaken, I went back and used TomoBridge and MetaMask to convert the 700 tokens I had remaining on my original Eth wallet and that went fine. Now I am trying to get those 96 ERC20 tokens on my Tomo wallet sent back back to the original Eth wallet in order to perform the conversion correctly]

Hi Hito,

I’m not quite sure about the issues that you had with MEW, Metamask and Ledger.

But you’ve successfully converted your TOMOE to TOMO on another wallet and I think you can just reproduce the process following the steps below:

  1. Log into your TomoWallet of the address you mistakenly sent TOMOE to (0x8350017834939CeD1e6918894d3AA3Ca6f30B0b4)
  2. Extract the private key of the address
  3. Log into your eth wallet with the private key you exported from step 2
  4. Now you should’ve seen you TOMOE in your wallet. Follow the steps to convert TOMOE to native TOMO via TomoBridge like you already did.

Let me know if it helps.

Good luck.

Hi Justin,

That TomoWallet, 0x8350017834939CeD1e6918894d3AA3Ca6f30B0b4, is on my Ledger under the TomoChain app. Is it possible to extract a private key off of a wallet on a Ledger?

Hi Hito, ledger wallet is private key by itself so you can’t extract private key from that, I can see that you have 96TOMOE on 0x8350017834939CeD1e6918894d3AA3Ca6f30B0b4 wallet. So now you can access that wallet then convert it to TOMO via TomoBridge

Hi Hoang,

The issue I have with TomoBridge is that when I try and convert the TOMOE tokens to TOMO is it requires me to use MetaMask. The wallet, 0x8350017834939CeD1e6918894d3AA3Ca6f30B0b4, is located on the TomoChain app on my Ledger. When I try and open up this wallet with MetaMask, it gives me an error and refuses to open in MetaMask. This is the error I get when I try and open the Tomo wallet in MetaMask to perform the TomoBridge swap: Imgur: The magic of the Internet.

Hey HitoKenshin,
i have the same problem!
how did you manage to move the tomoe tokens from your tomowallet?